GNU bug report logs - #11642
Libtool cannot find executables

Please note: This is a static page, with minimal formatting, updated once a day.
Click here to see this page with the latest information and nicer formatting.

Package: libtool; Reported by: Paul Barker <paul@HIDDEN>; dated Thu, 7 Jun 2012 00:46:02 UTC; Maintainer for libtool is bug-libtool@HIDDEN.

Message received at submit <at> debbugs.gnu.org:


Received: (at submit) by debbugs.gnu.org; 7 Jun 2012 00:45:27 +0000
From debbugs-submit-bounces <at> debbugs.gnu.org Wed Jun 06 20:45:27 2012
Received: from localhost ([127.0.0.1]:60970 helo=debbugs.gnu.org)
	by debbugs.gnu.org with esmtp (Exim 4.72)
	(envelope-from <debbugs-submit-bounces <at> debbugs.gnu.org>)
	id 1ScQqs-0005fO-UP
	for submit <at> debbugs.gnu.org; Wed, 06 Jun 2012 20:45:27 -0400
Received: from eggs.gnu.org ([208.118.235.92]:35781)
	by debbugs.gnu.org with esmtp (Exim 4.72)
	(envelope-from <paul@HIDDEN>) id 1ScQYz-0005DA-Qk
	for submit <at> debbugs.gnu.org; Wed, 06 Jun 2012 20:26:58 -0400
Received: from Debian-exim by eggs.gnu.org with spam-scanned (Exim 4.71)
	(envelope-from <paul@HIDDEN>) id 1ScQWm-0003wH-FW
	for submit <at> debbugs.gnu.org; Wed, 06 Jun 2012 20:24:41 -0400
X-Spam-Checker-Version: SpamAssassin 3.3.2 (2011-06-06) on eggs.gnu.org
X-Spam-Level: 
X-Spam-Status: No, score=-6.9 required=5.0 tests=BAYES_00,RCVD_IN_DNSWL_HI
	autolearn=unavailable version=3.3.2
Received: from lists.gnu.org ([208.118.235.17]:44690)
	by eggs.gnu.org with esmtp (Exim 4.71)
	(envelope-from <paul@HIDDEN>) id 1ScQWm-0003wC-CI
	for submit <at> debbugs.gnu.org; Wed, 06 Jun 2012 20:24:40 -0400
Received: from eggs.gnu.org ([208.118.235.92]:41073)
	by lists.gnu.org with esmtp (Exim 4.71)
	(envelope-from <paul@HIDDEN>) id 1ScQWk-0003X9-Qc
	for bug-libtool@HIDDEN; Wed, 06 Jun 2012 20:24:39 -0400
Received: from Debian-exim by eggs.gnu.org with spam-scanned (Exim 4.71)
	(envelope-from <paul@HIDDEN>) id 1ScQWj-0003vb-01
	for bug-libtool@HIDDEN; Wed, 06 Jun 2012 20:24:38 -0400
Received: from 11.mo4.mail-out.ovh.net ([46.105.34.195]:56099
	helo=mo4.mail-out.ovh.net) by eggs.gnu.org with esmtp (Exim 4.71)
	(envelope-from <paul@HIDDEN>) id 1ScQWi-0003vQ-Q4
	for bug-libtool@HIDDEN; Wed, 06 Jun 2012 20:24:36 -0400
Received: from mail187.ha.ovh.net (b7.ovh.net [213.186.33.57])
	by mo4.mail-out.ovh.net (Postfix) with SMTP id DC553104FBA2
	for <bug-libtool@HIDDEN>; Thu,  7 Jun 2012 02:27:04 +0200 (CEST)
Received: from b0.ovh.net (HELO queueout) (213.186.33.50)
	by b0.ovh.net with SMTP; 7 Jun 2012 02:24:34 +0200
Received: from 94-192-12-83.zone6.bethere.co.uk (HELO betafive.co.uk)
	(paul@HIDDEN@94.192.12.83)
	by ns0.ovh.net with SMTP; 7 Jun 2012 02:24:33 +0200
Received: from [192.168.0.100] (b5-desktop.betafive.co.uk [192.168.0.100])
	(Authenticated sender: paul)
	by betafive.co.uk (Postfix) with ESMTPA id 4AC0A4E61567
	for <bug-libtool@HIDDEN>; Thu,  7 Jun 2012 01:24:32 +0100 (IST)
Message-ID: <4FCFF4BF.9080007@HIDDEN>
Date: Thu, 07 Jun 2012 01:24:31 +0100
From: Paul Barker <paul@HIDDEN>
User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64;
	rv:12.0) Gecko/20120428 Thunderbird/12.0.1
MIME-Version: 1.0
To: bug-libtool@HIDDEN
X-Ovh-Mailout: 178.32.228.4 (mo4.mail-out.ovh.net)
Subject: Libtool cannot find executables
Content-Type: text/plain; charset=ISO-8859-1
Content-Transfer-Encoding: 7bit
X-Ovh-Tracer-Id: 17636377616229566817
X-Ovh-Remote: 94.192.12.83 (94-192-12-83.zone6.bethere.co.uk)
X-Ovh-Local: 213.186.33.20 (ns0.ovh.net)
X-OVH-SPAMSTATE: OK
X-OVH-SPAMSCORE: 0
X-OVH-SPAMCAUSE: gggruggvucftvghtrhhoucdtuddrfeegkedrtdeiucetufdoteggodetrfdofgetucfrrhhofhhilhgvmecuqfggjfenuceurghilhhouhhtmecufedttdenucenucfhrhhomheprfgruhhluceurghrkhgvrhcuoehprghulhesphgruhhlsggrrhhkvghrrdhmvgdruhhkqeenucfjughrpefkfffhfgggvffutgfgsehtjegrtddtfedu
X-VR-SPAMSTATE: OK
X-VR-SPAMSCORE: 0
X-VR-SPAMCAUSE: gggruggvucftvghtrhhoucdtuddrfeegkedrtdeiucetufdoteggodetrfdofgetucfrrhhofhhilhgvmecuqfggjfenuceurghilhhouhhtmecufedttdenucenucfhrhhomheprfgruhhluceurghrkhgvrhcuoehprghulhesphgruhhlsggrrhhkvghrrdhmvgdruhhkqeenucfjughrpefkfffhfgggvffutgfgsehtjegrtddtfedu
X-detected-operating-system: by eggs.gnu.org: Genre and OS details not
	recognized.
X-detected-operating-system: by eggs.gnu.org: GNU/Linux 2.6 (newer, 3)
X-Received-From: 208.118.235.17
X-Spam-Score: -6.2 (------)
X-Debbugs-Envelope-To: submit
X-Mailman-Approved-At: Wed, 06 Jun 2012 20:45:25 -0400
X-BeenThere: debbugs-submit <at> debbugs.gnu.org
X-Mailman-Version: 2.1.13
Precedence: list
List-Id: <debbugs-submit.debbugs.gnu.org>
List-Unsubscribe: <http://debbugs.gnu.org/cgi-bin/mailman/options/debbugs-submit>,
	<mailto:debbugs-submit-request <at> debbugs.gnu.org?subject=unsubscribe>
List-Archive: <http://debbugs.gnu.org/cgi-bin/mailman/private/debbugs-submit>
List-Post: <mailto:debbugs-submit <at> debbugs.gnu.org>
List-Help: <mailto:debbugs-submit-request <at> debbugs.gnu.org?subject=help>
List-Subscribe: <http://debbugs.gnu.org/cgi-bin/mailman/listinfo/debbugs-submit>,
	<mailto:debbugs-submit-request <at> debbugs.gnu.org?subject=subscribe>
Sender: debbugs-submit-bounces <at> debbugs.gnu.org
Errors-To: debbugs-submit-bounces <at> debbugs.gnu.org
X-Spam-Score: -6.2 (------)

Hi,

Libtools cannot find executables which are on my $PATH. This happens
when cross compiling two different packages, libsndfile-1.0.25 and
alsa-lib-1.0.25 (matching version numbers is coincidental). During
'make' everything runs fine, but both packages attempt to run additional
commands during 'make install' which seem not to belong in the install
phase. For libsndfile, libtool attempts to execute
arm-angstrom-linux-gnueabi-ranlib, my cross ranlib, but cannot find it.
For alsa-lib, libtool attempts to execute arm-angstrom-linux-gnueabi-gcc
but again cannot find it, despite the fact that it has been executing
the command correctly throughout the build of the library. My path is
set in ~/.bash_profile and is exported. My only guess is that libtool is
unsetting my $PATH variable during the install phase, but I may be very
wrong.

Thanks,

Paul Barker




Acknowledgement sent to Paul Barker <paul@HIDDEN>:
New bug report received and forwarded. Copy sent to bug-libtool@HIDDEN. Full text available.
Report forwarded to bug-libtool@HIDDEN:
bug#11642; Package libtool. Full text available.
Please note: This is a static page, with minimal formatting, updated once a day.
Click here to see this page with the latest information and nicer formatting.
Last modified: Fri, 31 Oct 2014 17:00:04 UTC

GNU bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997 nCipher Corporation Ltd, 1994-97 Ian Jackson.