GNU bug report logs - #14033
24.3.50; Deleting frame and reconnecting to Emacs daemon results in blank frame

Please note: This is a static page, with minimal formatting, updated once a day.
Click here to see this page with the latest information and nicer formatting.

Package: emacs; Reported by: Ulrich Mueller <ulm@HIDDEN>; dated Fri, 22 Mar 2013 20:13:02 UTC; Maintainer for emacs is bug-gnu-emacs@HIDDEN.

Message received at submit <at> debbugs.gnu.org:


Received: (at submit) by debbugs.gnu.org; 22 Mar 2013 20:12:25 +0000
From debbugs-submit-bounces <at> debbugs.gnu.org Fri Mar 22 16:12:25 2013
Received: from localhost ([127.0.0.1]:41248 helo=debbugs.gnu.org)
	by debbugs.gnu.org with esmtp (Exim 4.72)
	(envelope-from <debbugs-submit-bounces <at> debbugs.gnu.org>)
	id 1UJ8K9-0002L9-Dl
	for submit <at> debbugs.gnu.org; Fri, 22 Mar 2013 16:12:25 -0400
Received: from eggs.gnu.org ([208.118.235.92]:35146)
	by debbugs.gnu.org with esmtp (Exim 4.72)
	(envelope-from <ulm@HIDDEN>) id 1UJ8K6-0002Kv-O0
	for submit <at> debbugs.gnu.org; Fri, 22 Mar 2013 16:12:23 -0400
Received: from Debian-exim by eggs.gnu.org with spam-scanned (Exim 4.71)
	(envelope-from <ulm@HIDDEN>) id 1UJ8I6-00036O-9B
	for submit <at> debbugs.gnu.org; Fri, 22 Mar 2013 16:10:23 -0400
X-Spam-Checker-Version: SpamAssassin 3.3.2 (2011-06-06) on eggs.gnu.org
X-Spam-Level: 
X-Spam-Status: No, score=-104.4 required=5.0 tests=BAYES_00,RP_MATCHES_RCVD,
	USER_IN_WHITELIST autolearn=unavailable version=3.3.2
Received: from lists.gnu.org ([208.118.235.17]:42854)
	by eggs.gnu.org with esmtp (Exim 4.71)
	(envelope-from <ulm@HIDDEN>) id 1UJ8I6-00035y-5v
	for submit <at> debbugs.gnu.org; Fri, 22 Mar 2013 16:10:18 -0400
Received: from eggs.gnu.org ([208.118.235.92]:46083)
	by lists.gnu.org with esmtp (Exim 4.71)
	(envelope-from <ulm@HIDDEN>) id 1UJ8Fe-0006ZF-Um
	for bug-gnu-emacs@HIDDEN; Fri, 22 Mar 2013 16:07:49 -0400
Received: from Debian-exim by eggs.gnu.org with spam-scanned (Exim 4.71)
	(envelope-from <ulm@HIDDEN>) id 1UJ8Fb-0001rT-Mr
	for bug-gnu-emacs@HIDDEN; Fri, 22 Mar 2013 16:07:46 -0400
Received: from a1iwww1.kph.uni-mainz.de ([134.93.134.1]:41212
	helo=a1www.kph.uni-mainz.de) by eggs.gnu.org with esmtp (Exim 4.71)
	(envelope-from <ulm@HIDDEN>) id 1UJ8Fb-0001p3-Cr
	for bug-gnu-emacs@HIDDEN; Fri, 22 Mar 2013 16:07:43 -0400
Received: from a1i15.kph.uni-mainz.de (a1i15.kph.uni-mainz.de [134.93.134.92])
	by a1www.kph.uni-mainz.de (8.14.4/8.13.4) with ESMTP id
	r2MK7UB0014285
	for <bug-gnu-emacs@HIDDEN>; Fri, 22 Mar 2013 21:07:30 +0100
Received: from a1i15.kph.uni-mainz.de (localhost [127.0.0.1])
	by a1i15.kph.uni-mainz.de (8.14.6/8.14.2) with ESMTP id r2MK7U5Y011719; 
	Fri, 22 Mar 2013 21:07:30 +0100
Received: (from ulm@localhost)
	by a1i15.kph.uni-mainz.de (8.14.6/8.14.6/Submit) id r2MK7U9W011716;
	Fri, 22 Mar 2013 21:07:30 +0100
MIME-Version: 1.0
Content-Type: text/plain; charset=us-ascii
Content-Transfer-Encoding: 7bit
Message-ID: <20812.47615.543535.749761@HIDDEN>
Date: Fri, 22 Mar 2013 21:07:27 +0100
To: bug-gnu-emacs@HIDDEN
Subject: 24.3.50;
	Deleting frame and reconnecting to Emacs daemon results in blank frame
X-Mailer: VM 8.2.0b under 24.3.50.1 (x86_64-pc-linux-gnu)
From: Ulrich Mueller <ulm@HIDDEN>
X-detected-operating-system: by eggs.gnu.org: GNU/Linux 3.x
X-detected-operating-system: by eggs.gnu.org: GNU/Linux 2.6.x
X-Received-From: 208.118.235.17
X-Spam-Score: -6.9 (------)
X-Debbugs-Envelope-To: submit
X-BeenThere: debbugs-submit <at> debbugs.gnu.org
X-Mailman-Version: 2.1.13
Precedence: list
List-Id: <debbugs-submit.debbugs.gnu.org>
List-Unsubscribe: <http://debbugs.gnu.org/cgi-bin/mailman/options/debbugs-submit>,
	<mailto:debbugs-submit-request <at> debbugs.gnu.org?subject=unsubscribe>
List-Archive: <http://debbugs.gnu.org/cgi-bin/mailman/private/debbugs-submit>
List-Post: <mailto:debbugs-submit <at> debbugs.gnu.org>
List-Help: <mailto:debbugs-submit-request <at> debbugs.gnu.org?subject=help>
List-Subscribe: <http://debbugs.gnu.org/cgi-bin/mailman/listinfo/debbugs-submit>,
	<mailto:debbugs-submit-request <at> debbugs.gnu.org?subject=subscribe>
Sender: debbugs-submit-bounces <at> debbugs.gnu.org
Errors-To: debbugs-submit-bounces <at> debbugs.gnu.org
X-Spam-Score: -6.9 (------)

With Emacs from Bzr linked against Motif 2.3.4, I get a blank frame
when connecting for the second time to a daemonised Emacs.

To reproduce:

   $ emacs -Q --daemon
   $ emacsclient -c
   Waiting for Emacs...

Up to here everything appears to be o.k.
Now I delete the frame and try to connect for a second time:

   C-x 5 0
   $ emacsclient -c
   Waiting for Emacs...
   *ERROR*: X protocol error: RenderBadPicture (invalid Picture parameter) on protocol request 138

This time, I get above error message and a blank Emacs frame. (For the
menu bar, the background colour is visible, but otherwise it is also
blank. The toolbar is not visible at all.) Sometimes the error appears
only when connecting to the daemon for the third time.

The problem disappears when I disable the menu bar ("M-x menu-bar-mode
RET" before doing "C-x 5 0" the first time).


In GNU Emacs 24.3.50.1 (x86_64-pc-linux-gnu, Motif Version 2.3.4)
 of 2013-03-22 on juno
Bzr revision: kbrown@HIDDEN
Windowing system distributor `The X.Org Foundation', version 11.0.11400000
System Description:	Gentoo Base System release 2.2

Configured using:
 `configure --prefix=/usr --build=x86_64-pc-linux-gnu
 --host=x86_64-pc-linux-gnu --mandir=/usr/share/man
 --infodir=/usr/share/info --datadir=/usr/share --sysconfdir=/etc
 --localstatedir=/var/lib --libdir=/usr/lib64
 --disable-dependency-tracking --program-suffix=-emacs-24-vcs
 --program-transform-name=s/emacs-[0-9].*/emacs-24-vcs/
 --infodir=/usr/share/info/emacs-24-vcs
 --enable-locallisppath=/etc/emacs:/usr/share/emacs/site-lisp
 --with-gameuser=games --without-compress-info --without-hesiod
 --without-kerberos --without-kerberos5 --with-gpm --with-dbus
 --without-gnutls --with-inotify --with-acl --without-xml2
 --without-selinux --without-wide-int --with-sound --with-x
 --without-ns --without-gconf --without-gsettings
 --without-toolkit-scroll-bars --with-gif --with-jpeg --with-png
 --with-rsvg --with-tiff --with-xpm --with-imagemagick --with-xft
 --without-libotf --without-m17n-flt --with-x-toolkit=motif
 GENTOO_PACKAGE=app-editors/emacs-vcs-24.3.9999 EBZR_BRANCH=trunk
 EBZR_REVNO=112108 CFLAGS='-march=core2 -ggdb -O2 -pipe'
 LDFLAGS='-Wl,-O1 -Wl,--as-needed''


X resources (output of "appres Emacs"):
Emacs.geometry: 80x50-0-0
Emacs.font:	Droid Sans Mono-10
Emacs.foreground:	black
Emacs.background:	ivory
Emacs.cursorColor:	dark slate grey
Emacs.menuBar:	on
Emacs.scrollBarWidth:	8
Emacs.*.renderTable:	emacs
Emacs.*.renderTable.fontName:	Droid Sans
Emacs.*.renderTable.fontSize:	10
Emacs.*.renderTable.fontType:	FONT_IS_XFT
Emacs.pane.menubar.*.renderTable.fontStyle:	bold
*foreground:	black
*background:	ivory




Acknowledgement sent to Ulrich Mueller <ulm@HIDDEN>:
New bug report received and forwarded. Copy sent to bug-gnu-emacs@HIDDEN. Full text available.
Report forwarded to bug-gnu-emacs@HIDDEN:
bug#14033; Package emacs. Full text available.
Please note: This is a static page, with minimal formatting, updated once a day.
Click here to see this page with the latest information and nicer formatting.
Last modified: Fri, 31 Oct 2014 17:00:04 UTC

GNU bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997 nCipher Corporation Ltd, 1994-97 Ian Jackson.