GNU bug report logs - #14155
libtool 2.4.2 bug: default " sys_lib_dlsearch_path_spec" missing paths where LIBDIR=lib64

Please note: This is a static page, with minimal formatting, updated once a day.
Click here to see this page with the latest information and nicer formatting.

Package: libtool; Reported by: ar16@HIDDEN; dated Sun, 7 Apr 2013 18:42:02 UTC; Maintainer for libtool is bug-libtool@HIDDEN.

Message received at submit <at> debbugs.gnu.org:


Received: (at submit) by debbugs.gnu.org; 7 Apr 2013 18:41:16 +0000
From debbugs-submit-bounces <at> debbugs.gnu.org Sun Apr 07 14:41:16 2013
Received: from localhost ([127.0.0.1]:38742 helo=debbugs.gnu.org)
	by debbugs.gnu.org with esmtp (Exim 4.72)
	(envelope-from <debbugs-submit-bounces <at> debbugs.gnu.org>)
	id 1UOuWf-00042z-EH
	for submit <at> debbugs.gnu.org; Sun, 07 Apr 2013 14:41:15 -0400
Received: from eggs.gnu.org ([208.118.235.92]:46019)
	by debbugs.gnu.org with esmtp (Exim 4.72)
	(envelope-from <ar16@HIDDEN>) id 1UOuSM-0003ur-Gt
	for submit <at> debbugs.gnu.org; Sun, 07 Apr 2013 14:36:47 -0400
Received: from Debian-exim by eggs.gnu.org with spam-scanned (Exim 4.71)
	(envelope-from <ar16@HIDDEN>) id 1UOuOt-0004UF-07
	for submit <at> debbugs.gnu.org; Sun, 07 Apr 2013 14:33:18 -0400
X-Spam-Checker-Version: SpamAssassin 3.3.2 (2011-06-06) on eggs.gnu.org
X-Spam-Level: 
X-Spam-Status: No, score=-0.4 required=5.0 tests=BAYES_20,
	FREEMAIL_ENVFROM_END_DIGIT, FREEMAIL_FROM, RCVD_IN_DNSWL_LOW,
	T_DKIM_INVALID autolearn=disabled version=3.3.2
Received: from lists.gnu.org ([208.118.235.17]:41454)
	by eggs.gnu.org with esmtp (Exim 4.71)
	(envelope-from <ar16@HIDDEN>) id 1UOuOs-0004U8-TM
	for submit <at> debbugs.gnu.org; Sun, 07 Apr 2013 14:33:10 -0400
Received: from eggs.gnu.org ([208.118.235.92]:57303)
	by lists.gnu.org with esmtp (Exim 4.71)
	(envelope-from <ar16@HIDDEN>) id 1UOuOl-0003gc-Ek
	for bug-libtool@HIDDEN; Sun, 07 Apr 2013 14:33:10 -0400
Received: from Debian-exim by eggs.gnu.org with spam-scanned (Exim 4.71)
	(envelope-from <ar16@HIDDEN>) id 1UOuOf-0004R5-P1
	for bug-libtool@HIDDEN; Sun, 07 Apr 2013 14:33:03 -0400
Received: from out1-smtp.messagingengine.com ([66.111.4.25]:60374)
	by eggs.gnu.org with esmtp (Exim 4.71)
	(envelope-from <ar16@HIDDEN>) id 1UOuOf-0004Ql-He
	for bug-libtool@HIDDEN; Sun, 07 Apr 2013 14:32:57 -0400
Received: from compute5.internal (compute5.nyi.mail.srv.osa [10.202.2.45])
	by gateway1.nyi.mail.srv.osa (Postfix) with ESMTP id EB73D2000C;
	Sun,  7 Apr 2013 14:32:55 -0400 (EDT)
Received: from web1.nyi.mail.srv.osa ([10.202.2.211])
	by compute5.internal (MEProxy); Sun, 07 Apr 2013 14:32:55 -0400
DKIM-Signature: v=1; a=rsa-sha1; c=relaxed/relaxed; d=imapmail.org; h=
	message-id:from:to:cc:mime-version:content-transfer-encoding
	:content-type:subject:date; s=mesmtp; bh=Ofk4CQiEpq7lx2qn/SrwUlq
	F25w=; b=ZdtbDS1nEsKBAP2apAcdltuktDCzmUiKmFWmW4ZKfUt5oKHIc16ooXd
	ylljOaifAdIrmuTNevMg7v+Rn8ltaGz0cKDEnwhldfItSwkXu4rasRiOZ84mCl8I
	TEpL10PQY/D5bEyVGT33P6gY91YlgFzW61alkwwZAtNW9SyUJCWg=
DKIM-Signature: v=1; a=rsa-sha1; c=relaxed/relaxed; d=
	messagingengine.com; h=message-id:from:to:cc:mime-version
	:content-transfer-encoding:content-type:subject:date; s=smtpout;
	bh=Ofk4CQiEpq7lx2qn/SrwUlqF25w=; b=HZLC5gqxK+Zd1TknI51HpkUpLDOv
	iAtMMomBuYTAw1/CgOZkFAMTzMINLZEti1q9OuXu7s+a5Da8rKLHViCzbUwYsxta
	2OxsGLjvmqyV+FsZIpJSPKM0Jt1TZB4ICPdPP3dq2mAIWGIvaJInPvgDeW1hBQ8j
	BXjoOVRpXlhRLDc=
Received: by web1.nyi.mail.srv.osa (Postfix, from userid 99)
	id C43D7B80003; Sun,  7 Apr 2013 14:32:55 -0400 (EDT)
Message-Id: <1365359575.11605.140661214516817.1E356C38@HIDDEN>
X-Sasl-Enc: koYwSUGE495aqY2ooFcEgn+x3L6XR60Zlt3fKh2LnPC3 1365359575
From: ar16@HIDDEN
To: bug-libtool@HIDDEN
MIME-Version: 1.0
Content-Transfer-Encoding: 7bit
Content-Type: text/plain
X-Mailer: MessagingEngine.com Webmail Interface - ajax-a248d092
Subject: libtool 2.4.2 bug: default " sys_lib_dlsearch_path_spec" missing paths
	where LIBDIR=lib64
Date: Sun, 07 Apr 2013 11:32:55 -0700
X-detected-operating-system: by eggs.gnu.org: Genre and OS details not
	recognized.
X-detected-operating-system: by eggs.gnu.org: GNU/Linux 2.6.x
X-Received-From: 208.118.235.17
X-Spam-Score: -3.2 (---)
X-Debbugs-Envelope-To: submit
X-Mailman-Approved-At: Sun, 07 Apr 2013 14:41:12 -0400
Cc: pth@HIDDEN
X-BeenThere: debbugs-submit <at> debbugs.gnu.org
X-Mailman-Version: 2.1.13
Precedence: list
List-Id: <debbugs-submit.debbugs.gnu.org>
List-Unsubscribe: <http://debbugs.gnu.org/cgi-bin/mailman/options/debbugs-submit>,
	<mailto:debbugs-submit-request <at> debbugs.gnu.org?subject=unsubscribe>
List-Archive: <http://debbugs.gnu.org/cgi-bin/mailman/private/debbugs-submit>
List-Post: <mailto:debbugs-submit <at> debbugs.gnu.org>
List-Help: <mailto:debbugs-submit-request <at> debbugs.gnu.org?subject=help>
List-Subscribe: <http://debbugs.gnu.org/cgi-bin/mailman/listinfo/debbugs-submit>,
	<mailto:debbugs-submit-request <at> debbugs.gnu.org?subject=subscribe>
Sender: debbugs-submit-bounces <at> debbugs.gnu.org
Errors-To: debbugs-submit-bounces <at> debbugs.gnu.org
X-Spam-Score: -5.9 (-----)

I've

	libtool --version
		libtool (GNU libtool) 2.4.2
		Written by Gordon Matzigkeit <gord@HIDDEN>, 1996

		Copyright (C) 2011 Free Software Foundation, Inc.
		This is free software; see the source for copying
		conditions.  There is NO
		warranty; not even for MERCHANTABILITY or FITNESS FOR A
		PARTICULAR PURPOSE.

on

	lsb_release -a
		LSB Version:   
		core-2.0-noarch:core-3.2-noarch:core-4.0-noarch:core-2.0-x86_64:core-3.2-x86_64:core-4.0-x86_64:desktop-4.0-amd64:desktop-4.0-noarch:graphics-2.0-amd64:graphics-2.0-noarch:graphics-3.2-amd64:graphics-3.2-noarch:graphics-4.0-amd64:graphics-4.0-noarch
		Distributor ID: openSUSE project
		Description:    openSUSE 12.3 (x86_64)
		Release:        12.3
		Codename:       Dartmouth


I originally reported this @ Opensuse bugzilla

	https://bugzilla.novell.com/show_bug.cgi?id=786460

but was told to report it upstream.  IMO, the issue is directly related
to Opensuse's use of LIBDIR=lib64 on X86_64 systems, and should be
patched THERE, but ... here's the issue:

For installed libtool, checking

	grep ^sys_lib_dlsearch_path_spec /usr/bin/libtool
	    sys_lib_dlsearch_path_spec="/lib /usr/lib /usr/local/lib64
	    /usr/local/lib "

the as-installed default fails to include the libdirs as used on X86_64
systems on Opensuse (and perhaps others that do the same ...).

On x86_64 that shouldn't be "/lib /usr/lib", but rather "/lib64
/usr/lib64".

arguably, /usr/lib/lib64 should lead the order ...




Acknowledgement sent to ar16@HIDDEN:
New bug report received and forwarded. Copy sent to bug-libtool@HIDDEN. Full text available.
Report forwarded to bug-libtool@HIDDEN:
bug#14155; Package libtool. Full text available.
Please note: This is a static page, with minimal formatting, updated once a day.
Click here to see this page with the latest information and nicer formatting.
Last modified: Fri, 31 Oct 2014 17:00:04 UTC

GNU bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997 nCipher Corporation Ltd, 1994-97 Ian Jackson.