GNU bug report logs - #14519
Missing dlname='' in uninstalled .la file

Please note: This is a static page, with minimal formatting, updated once a day.
Click here to see this page with the latest information and nicer formatting.

Package: libtool; Reported by: Ryan Lortie <desrt@HIDDEN>; dated Fri, 31 May 2013 14:02:01 UTC; Maintainer for libtool is bug-libtool@HIDDEN.

Message received at submit <at> debbugs.gnu.org:


Received: (at submit) by debbugs.gnu.org; 31 May 2013 14:01:09 +0000
From debbugs-submit-bounces <at> debbugs.gnu.org Fri May 31 10:01:09 2013
Received: from localhost ([127.0.0.1]:44528 helo=debbugs.gnu.org)
	by debbugs.gnu.org with esmtp (Exim 4.72)
	(envelope-from <debbugs-submit-bounces <at> debbugs.gnu.org>)
	id 1UiPtE-0000D2-N4
	for submit <at> debbugs.gnu.org; Fri, 31 May 2013 10:01:09 -0400
Received: from eggs.gnu.org ([208.118.235.92]:51278)
	by debbugs.gnu.org with esmtp (Exim 4.72)
	(envelope-from <desrt@HIDDEN>) id 1UiPt9-0000C1-Ql
	for submit <at> debbugs.gnu.org; Fri, 31 May 2013 10:01:04 -0400
Received: from Debian-exim by eggs.gnu.org with spam-scanned (Exim 4.71)
	(envelope-from <desrt@HIDDEN>) id 1UiPrU-0006Wg-NW
	for submit <at> debbugs.gnu.org; Fri, 31 May 2013 09:59:23 -0400
X-Spam-Checker-Version: SpamAssassin 3.3.2 (2011-06-06) on eggs.gnu.org
X-Spam-Level: 
X-Spam-Status: No, score=-1.9 required=5.0 tests=BAYES_00,T_DKIM_INVALID
	autolearn=disabled version=3.3.2
Received: from lists.gnu.org ([2001:4830:134:3::11]:47946)
	by eggs.gnu.org with esmtp (Exim 4.71)
	(envelope-from <desrt@HIDDEN>) id 1UiPrU-0006Wc-Kb
	for submit <at> debbugs.gnu.org; Fri, 31 May 2013 09:59:20 -0400
Received: from eggs.gnu.org ([2001:4830:134:3::10]:52999)
	by lists.gnu.org with esmtp (Exim 4.71)
	(envelope-from <desrt@HIDDEN>) id 1UiPrS-0007Xx-5O
	for bug-libtool@HIDDEN; Fri, 31 May 2013 09:59:20 -0400
Received: from Debian-exim by eggs.gnu.org with spam-scanned (Exim 4.71)
	(envelope-from <desrt@HIDDEN>) id 1UiPrP-0006WC-P0
	for bug-libtool@HIDDEN; Fri, 31 May 2013 09:59:18 -0400
Received: from out1-smtp.messagingengine.com ([66.111.4.25]:53846)
	by eggs.gnu.org with esmtp (Exim 4.71)
	(envelope-from <desrt@HIDDEN>) id 1UiPrP-0006W6-L6
	for bug-libtool@HIDDEN; Fri, 31 May 2013 09:59:15 -0400
Received: from compute4.internal (compute4.nyi.mail.srv.osa [10.202.2.44])
	by gateway1.nyi.mail.srv.osa (Postfix) with ESMTP id B636320C53
	for <bug-libtool@HIDDEN>; Fri, 31 May 2013 09:51:12 -0400 (EDT)
Received: from web6.nyi.mail.srv.osa ([10.202.2.216])
	by compute4.internal (MEProxy); Fri, 31 May 2013 09:51:12 -0400
DKIM-Signature: v=1; a=rsa-sha1; c=relaxed/relaxed; d=
	messagingengine.com; h=message-id:from:to:mime-version
	:content-transfer-encoding:content-type:subject:date; s=smtpout;
	bh=ONqnLnEgKfLZKjCqXzosnCtCcw8=; b=qt8Zia+yqeA1f0TXFQy9TsPQW3u1
	ntjSiVCXcYLx16FTPkPPMcj8LYpwozmeOsYiTpyyApUjdRClTg9V084U4FPwBLGx
	s71X63b8U217lR/qgtbpUYowAyvZ+Iy3UheOXF09i/HlKKMENUzToZRj18Wn1Nci
	zSSmxVODBVMPmo0=
Received: by web6.nyi.mail.srv.osa (Postfix, from userid 99)
	id 91EA640157; Fri, 31 May 2013 09:51:12 -0400 (EDT)
Message-Id: <1370008272.17915.140661238116585.0945FED1@HIDDEN>
X-Sasl-Enc: +7KUdDWIZnHFDU97e2hhtPvptt4t1mWKWraPnnL9VQJ3 1370008272
From: Ryan Lortie <desrt@HIDDEN>
To: bug-libtool@HIDDEN
MIME-Version: 1.0
Content-Transfer-Encoding: 7bit
Content-Type: text/plain
X-Mailer: MessagingEngine.com Webmail Interface - ajax-5ebcfc6a
Subject: Missing dlname='' in uninstalled .la file
Date: Fri, 31 May 2013 09:51:12 -0400
X-detected-operating-system: by eggs.gnu.org: Genre and OS details not
	recognized.
X-detected-operating-system: by eggs.gnu.org: Error: Malformed IPv6 address
	(bad octet value).
X-Received-From: 2001:4830:134:3::11
X-Spam-Score: -4.2 (----)
X-Debbugs-Envelope-To: submit
X-BeenThere: debbugs-submit <at> debbugs.gnu.org
X-Mailman-Version: 2.1.13
Precedence: list
List-Id: <debbugs-submit.debbugs.gnu.org>
List-Unsubscribe: <http://debbugs.gnu.org/cgi-bin/mailman/options/debbugs-submit>,
	<mailto:debbugs-submit-request <at> debbugs.gnu.org?subject=unsubscribe>
List-Archive: <http://debbugs.gnu.org/cgi-bin/mailman/private/debbugs-submit>
List-Post: <mailto:debbugs-submit <at> debbugs.gnu.org>
List-Help: <mailto:debbugs-submit-request <at> debbugs.gnu.org?subject=help>
List-Subscribe: <http://debbugs.gnu.org/cgi-bin/mailman/listinfo/debbugs-submit>,
	<mailto:debbugs-submit-request <at> debbugs.gnu.org?subject=subscribe>
Sender: debbugs-submit-bounces <at> debbugs.gnu.org
Errors-To: debbugs-submit-bounces <at> debbugs.gnu.org
X-Spam-Score: -6.9 (------)

hi,

It seems that if I use libtool to generate a .la file that won't be
installed (from noinst_LTLIBRARIES or check_LTLIBRARIES for example)
then automake doesn't pass the -rpath parameter to libtool.

(I think) libtool then assumes that, because this library will never be
installed, nobody will ever want to open it with libltdl.  It writes
dlname='' to the .la file instead of the real name.  This happens even
if -module is explicitly given.  Having an empty dlname='' causes
libltdl not to be able to open the module.

My intention was to build this library to be dlopen()ed by a testcase,
so I think the dlname='' line should always be correctly filled in -- or
at least when using '-module'.

Thanks in advance.




Acknowledgement sent to Ryan Lortie <desrt@HIDDEN>:
New bug report received and forwarded. Copy sent to bug-libtool@HIDDEN. Full text available.
Report forwarded to bug-libtool@HIDDEN:
bug#14519; Package libtool. Full text available.
Please note: This is a static page, with minimal formatting, updated once a day.
Click here to see this page with the latest information and nicer formatting.
Last modified: Fri, 31 Oct 2014 17:00:04 UTC

GNU bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997 nCipher Corporation Ltd, 1994-97 Ian Jackson.