GNU bug report logs - #16000
emacs hangs at start

Please note: This is a static page, with minimal formatting, updated once a day.
Click here to see this page with the latest information and nicer formatting.

Package: emacs; Reported by: glux <sentinelum@HIDDEN>; dated Fri, 29 Nov 2013 17:56:02 UTC; Maintainer for emacs is bug-gnu-emacs@HIDDEN.

Message received at submit <at> debbugs.gnu.org:


Received: (at submit) by debbugs.gnu.org; 29 Nov 2013 17:55:23 +0000
From debbugs-submit-bounces <at> debbugs.gnu.org Fri Nov 29 12:55:22 2013
Received: from localhost ([127.0.0.1]:50489 helo=debbugs.gnu.org)
	by debbugs.gnu.org with esmtp (Exim 4.80)
	(envelope-from <debbugs-submit-bounces <at> debbugs.gnu.org>)
	id 1VmSHf-0004Sl-5A
	for submit <at> debbugs.gnu.org; Fri, 29 Nov 2013 12:55:20 -0500
Received: from eggs.gnu.org ([208.118.235.92]:35406)
 by debbugs.gnu.org with esmtp (Exim 4.80)
 (envelope-from <sentinelum@HIDDEN>) id 1VmJoM-0006iK-Lz
 for submit <at> debbugs.gnu.org; Fri, 29 Nov 2013 03:52:32 -0500
Received: from Debian-exim by eggs.gnu.org with spam-scanned (Exim 4.71)
 (envelope-from <sentinelum@HIDDEN>) id 1VmJoB-0000y5-Lo
 for submit <at> debbugs.gnu.org; Fri, 29 Nov 2013 03:52:25 -0500
X-Spam-Checker-Version: SpamAssassin 3.3.2 (2011-06-06) on eggs.gnu.org
X-Spam-Level: *
X-Spam-Status: No, score=1.9 required=5.0 tests=BAYES_50,URI_HEX
 autolearn=disabled version=3.3.2
Received: from lists.gnu.org ([2001:4830:134:3::11]:60828)
 by eggs.gnu.org with esmtp (Exim 4.71)
 (envelope-from <sentinelum@HIDDEN>) id 1VmJoB-0000y1-JD
 for submit <at> debbugs.gnu.org; Fri, 29 Nov 2013 03:52:19 -0500
Received: from eggs.gnu.org ([2001:4830:134:3::10]:37099)
 by lists.gnu.org with esmtp (Exim 4.71)
 (envelope-from <sentinelum@HIDDEN>) id 1VmJo6-0005ji-Hd
 for Bug-gnu-emacs@HIDDEN; Fri, 29 Nov 2013 03:52:19 -0500
Received: from Debian-exim by eggs.gnu.org with spam-scanned (Exim 4.71)
 (envelope-from <sentinelum@HIDDEN>) id 1VmJo1-0000ul-H0
 for Bug-gnu-emacs@HIDDEN; Fri, 29 Nov 2013 03:52:14 -0500
Received: from sam.nabble.com ([216.139.236.26]:45142)
 by eggs.gnu.org with esmtp (Exim 4.71)
 (envelope-from <sentinelum@HIDDEN>) id 1VmJo1-0000uh-CF
 for Bug-gnu-emacs@HIDDEN; Fri, 29 Nov 2013 03:52:09 -0500
Received: from [192.168.236.26] (helo=sam.nabble.com)
 by sam.nabble.com with esmtp (Exim 4.72)
 (envelope-from <sentinelum@HIDDEN>) id 1VmJo0-0002Az-4j
 for Bug-gnu-emacs@HIDDEN; Fri, 29 Nov 2013 00:52:08 -0800
Date: Fri, 29 Nov 2013 00:52:08 -0800 (PST)
From: glux <sentinelum@HIDDEN>
To: Bug-gnu-emacs@HIDDEN
Message-ID: <1385715127762-304290.post@HIDDEN>
Subject: emacs hangs at start
MIME-Version: 1.0
Content-Type: text/plain; charset=us-ascii
Content-Transfer-Encoding: 7bit
X-detected-operating-system: by eggs.gnu.org: GNU/Linux 2.6.x
X-detected-operating-system: by eggs.gnu.org: Error: Malformed IPv6 address
 (bad octet value).
X-Received-From: 2001:4830:134:3::11
X-Spam-Score: -3.7 (---)
X-Debbugs-Envelope-To: submit
X-Mailman-Approved-At: Fri, 29 Nov 2013 12:55:14 -0500
X-BeenThere: debbugs-submit <at> debbugs.gnu.org
X-Mailman-Version: 2.1.15
Precedence: list
List-Id: <debbugs-submit.debbugs.gnu.org>
List-Unsubscribe: <http://debbugs.gnu.org/cgi-bin/mailman/options/debbugs-submit>, 
 <mailto:debbugs-submit-request <at> debbugs.gnu.org?subject=unsubscribe>
List-Archive: <http://debbugs.gnu.org/cgi-bin/mailman/private/debbugs-submit/>
List-Post: <mailto:debbugs-submit <at> debbugs.gnu.org>
List-Help: <mailto:debbugs-submit-request <at> debbugs.gnu.org?subject=help>
List-Subscribe: <http://debbugs.gnu.org/cgi-bin/mailman/listinfo/debbugs-submit>, 
 <mailto:debbugs-submit-request <at> debbugs.gnu.org?subject=subscribe>
Errors-To: debbugs-submit-bounces <at> debbugs.gnu.org
Sender: "Debbugs-submit" <debbugs-submit-bounces <at> debbugs.gnu.org>
X-Spam-Score: -3.7 (---)

I have upgraded my openSuSe Linux to the new 13.1 version which includes
emacs 24.3.1 GTK version.

When logging in via SSH (putty) and starting emacs th esession will freeze
accepting no input at all.

It appears the Problem is probably linked to the use of dbus. While this is
a SSH session and DISPLAY is not defined emacs start emacs-gtk with dbus. As
soon as I send a kill to th edbus-luanch process created, emacs stops the
freeze and I get control.

There have been several Posts about starting emacs without dbus which are
not realy practical in my case:

1. Compile without dbus support: no Option as I want to use the stock
pre-compiled emacs
2. DISPLAY=emacs --daemon: works, but rather a Workaround than a solution
3. env DBUS_SESSION_BUS_ADDRESS=unix:path=/tmp/foo emacs: Also a workaround,
and did also not work when I tested it

The only proper solution in my eyes would be to have an emacs Option like
--no-dbus as suggested in another bug to disable dbus at start.

So at least one would have control over dbus. This does not exclude
investigating the hang of course.




--
View this message in context: http://emacs.1067599.n5.nabble.com/emacs-hangs-at-start-tp304290.html
Sent from the Emacs - Bugs mailing list archive at Nabble.com.




Acknowledgement sent to glux <sentinelum@HIDDEN>:
New bug report received and forwarded. Copy sent to bug-gnu-emacs@HIDDEN. Full text available.
Report forwarded to bug-gnu-emacs@HIDDEN:
bug#16000; Package emacs. Full text available.
Please note: This is a static page, with minimal formatting, updated once a day.
Click here to see this page with the latest information and nicer formatting.
Last modified: Fri, 31 Oct 2014 17:00:04 UTC

GNU bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997 nCipher Corporation Ltd, 1994-97 Ian Jackson.