GNU bug report logs - #33047
pypi importer uses incorrect package names

Please note: This is a static page, with minimal formatting, updated once a day.
Click here to see this page with the latest information and nicer formatting.

Package: guix; Reported by: Julien Lepiller <julien@HIDDEN>; dated Mon, 15 Oct 2018 13:44:02 UTC; Maintainer for guix is bug-guix@HIDDEN.

Message received at submit <at> debbugs.gnu.org:


Received: (at submit) by debbugs.gnu.org; 15 Oct 2018 13:43:22 +0000
From debbugs-submit-bounces <at> debbugs.gnu.org Mon Oct 15 09:43:22 2018
Received: from localhost ([127.0.0.1]:49964 helo=debbugs.gnu.org)
	by debbugs.gnu.org with esmtp (Exim 4.84_2)
	(envelope-from <debbugs-submit-bounces <at> debbugs.gnu.org>)
	id 1gC39U-00020h-Vn
	for submit <at> debbugs.gnu.org; Mon, 15 Oct 2018 09:43:22 -0400
Received: from eggs.gnu.org ([208.118.235.92]:59022)
 by debbugs.gnu.org with esmtp (Exim 4.84_2)
 (envelope-from <julien@HIDDEN>) id 1gC39S-00020U-PJ
 for submit <at> debbugs.gnu.org; Mon, 15 Oct 2018 09:43:19 -0400
Received: from Debian-exim by eggs.gnu.org with spam-scanned (Exim 4.71)
 (envelope-from <julien@HIDDEN>) id 1gC39K-0005EP-JU
 for submit <at> debbugs.gnu.org; Mon, 15 Oct 2018 09:43:12 -0400
X-Spam-Checker-Version: SpamAssassin 3.3.2 (2011-06-06) on eggs.gnu.org
X-Spam-Level: 
X-Spam-Status: No, score=-0.0 required=5.0 tests=BAYES_40 autolearn=disabled
 version=3.3.2
Received: from lists.gnu.org ([2001:4830:134:3::11]:53553)
 by eggs.gnu.org with esmtps (TLS1.0:RSA_AES_256_CBC_SHA1:32)
 (Exim 4.71) (envelope-from <julien@HIDDEN>) id 1gC39K-0005EJ-FB
 for submit <at> debbugs.gnu.org; Mon, 15 Oct 2018 09:43:10 -0400
Received: from eggs.gnu.org ([2001:4830:134:3::10]:40378)
 by lists.gnu.org with esmtp (Exim 4.71)
 (envelope-from <julien@HIDDEN>) id 1gC39J-0001k8-Od
 for bug-guix@HIDDEN; Mon, 15 Oct 2018 09:43:10 -0400
Received: from Debian-exim by eggs.gnu.org with spam-scanned (Exim 4.71)
 (envelope-from <julien@HIDDEN>) id 1gC39F-0005BN-Kg
 for bug-guix@HIDDEN; Mon, 15 Oct 2018 09:43:09 -0400
Received: from lepiller.eu ([2a00:5884:8208::1]:35348)
 by eggs.gnu.org with esmtps (TLS1.0:DHE_RSA_AES_256_CBC_SHA1:32)
 (Exim 4.71) (envelope-from <julien@HIDDEN>) id 1gC39F-0005AY-9P
 for bug-guix@HIDDEN; Mon, 15 Oct 2018 09:43:05 -0400
Received: from webmail.lepiller.eu (static-176-182-42-79.ncc.abo.bbox.fr
 [176.182.42.79]) by lepiller.eu (OpenSMTPD) with ESMTPSA id 85ee2d75
 (TLSv1.2:ECDHE-RSA-AES256-GCM-SHA384:256:NO) for <bug-guix@HIDDEN>;
 Mon, 15 Oct 2018 13:42:32 +0000 (UTC)
MIME-Version: 1.0
Content-Type: text/plain; charset=US-ASCII;
 format=flowed
Content-Transfer-Encoding: 7bit
Date: Mon, 15 Oct 2018 15:43:02 +0200
From: Julien Lepiller <julien@HIDDEN>
To: bug-guix@HIDDEN
Subject: pypi importer uses incorrect package names
Message-ID: <e5965fe7462e7825cfe61169762a3562@HIDDEN>
X-Sender: julien@HIDDEN
User-Agent: Roundcube Webmail/1.3.6
X-detected-operating-system: by eggs.gnu.org: Genre and OS details not
 recognized.
X-detected-operating-system: by eggs.gnu.org: GNU/Linux 2.6.x
X-Received-From: 2001:4830:134:3::11
X-Spam-Score: -5.0 (-----)
X-Debbugs-Envelope-To: submit
X-BeenThere: debbugs-submit <at> debbugs.gnu.org
X-Mailman-Version: 2.1.18
Precedence: list
List-Id: <debbugs-submit.debbugs.gnu.org>
List-Unsubscribe: <https://debbugs.gnu.org/cgi-bin/mailman/options/debbugs-submit>, 
 <mailto:debbugs-submit-request <at> debbugs.gnu.org?subject=unsubscribe>
List-Archive: <https://debbugs.gnu.org/cgi-bin/mailman/private/debbugs-submit/>
List-Post: <mailto:debbugs-submit <at> debbugs.gnu.org>
List-Help: <mailto:debbugs-submit-request <at> debbugs.gnu.org?subject=help>
List-Subscribe: <https://debbugs.gnu.org/cgi-bin/mailman/listinfo/debbugs-submit>, 
 <mailto:debbugs-submit-request <at> debbugs.gnu.org?subject=subscribe>
Errors-To: debbugs-submit-bounces <at> debbugs.gnu.org
Sender: "Debbugs-submit" <debbugs-submit-bounces <at> debbugs.gnu.org>
X-Spam-Score: -6.0 (------)

Hi,

I found that sometimes the pypi importer had trouble importing packages 
correctly. For instance, running "guix import pypi txaio" gave me this 
list of dependencies:

(propagated-inputs
  `(("python-[all]" ,#{python-\x5b;all\x5d;}#)
    ("python-[asyncio]"
     ,#{python-\x5b;asyncio\x5d;}#)
    ...))

guix import pypi magic-wormhole had this:

(propagated-inputs
   ("python-autobahn[twisted]"
    ,#{python-autobahn\x5b;twisted\x5d;}#)
   ...))

Of course, they break the recursive importer, which makes it difficult 
to import these packages correctly.




Acknowledgement sent to Julien Lepiller <julien@HIDDEN>:
New bug report received and forwarded. Copy sent to bug-guix@HIDDEN. Full text available.
Report forwarded to bug-guix@HIDDEN:
bug#33047; Package guix. Full text available.
Please note: This is a static page, with minimal formatting, updated once a day.
Click here to see this page with the latest information and nicer formatting.
Last modified: Mon, 15 Oct 2018 13:45:01 UTC

GNU bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997 nCipher Corporation Ltd, 1994-97 Ian Jackson.