GNU bug report logs - #7328
parallel installation ignores deps between libtool libraries

Please note: This is a static page, with minimal formatting, updated once a day.
Click here to see this page with the latest information and nicer formatting.

Package: automake; Reported by: Andy Wingo <wingo@HIDDEN>; dated Thu, 4 Nov 2010 15:27:01 UTC; Maintainer for automake is bug-automake@HIDDEN.

Message received at 7328 <at> debbugs.gnu.org:


Received: (at 7328) by debbugs.gnu.org; 29 Mar 2013 23:09:21 +0000
From debbugs-submit-bounces <at> debbugs.gnu.org Fri Mar 29 19:09:21 2013
Received: from localhost ([127.0.0.1]:51521 helo=debbugs.gnu.org)
	by debbugs.gnu.org with esmtp (Exim 4.72)
	(envelope-from <debbugs-submit-bounces <at> debbugs.gnu.org>)
	id 1ULiQD-0003kF-IL
	for submit <at> debbugs.gnu.org; Fri, 29 Mar 2013 19:09:21 -0400
Received: from mail-ea0-f180.google.com ([209.85.215.180]:34420)
	by debbugs.gnu.org with esmtp (Exim 4.72)
	(envelope-from <stefano.lattarini@HIDDEN>) id 1ULiQA-0003k6-92
	for 7328 <at> debbugs.gnu.org; Fri, 29 Mar 2013 19:09:18 -0400
Received: by mail-ea0-f180.google.com with SMTP id d10so377403eaj.11
	for <7328 <at> debbugs.gnu.org>; Fri, 29 Mar 2013 16:06:39 -0700 (PDT)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=20120113;
	h=x-received:message-id:date:from:mime-version:to:cc:subject
	:references:in-reply-to:content-type:content-transfer-encoding;
	bh=kzD8Qsq+H9cc+km86ItS1Xu1ELXW0s78+uhN4d7yqPw=;
	b=jm9XvBvk7zNgW0lU/43JR2QN1Daw9USi+YsnxcaZmJRMW73QkfvYG6VczAfkpsPfQ+
	XrWPl03YI/5G1rIXltDxlAQGOfx3uASRmxKhBlvHHougQkSxNg5LrBFl6x8yXw0xWOje
	4ewsdoDmPshitzKJEhk/JG/gags9Mi99YkaFSlG2NAe1PJLsl10L0R8/N4N711/YuPGP
	F+cPK6kuNYIn3UgmRBnPBwm/9FaEFtgPuuL8Tp0GTfp3nHDnIsmO3dEnFgfyDI7RjQXl
	GWXv+AWWlXgBC1lFmr6QvECt/2+4I6+fpDV7dsCKW/TMBFUFxVvY6/R5xuB/uCSi4FYM
	P/wg==
X-Received: by 10.14.216.2 with SMTP id f2mr12147306eep.44.1364598399537;
	Fri, 29 Mar 2013 16:06:39 -0700 (PDT)
Received: from [192.168.178.20]
	(host93-95-dynamic.6-79-r.retail.telecomitalia.it. [79.6.95.93])
	by mx.google.com with ESMTPS id bc1sm6790348eeb.11.2013.03.29.16.06.37
	(version=TLSv1 cipher=ECDHE-RSA-RC4-SHA bits=128/128);
	Fri, 29 Mar 2013 16:06:38 -0700 (PDT)
Message-ID: <51561E7C.1020006@HIDDEN>
Date: Sat, 30 Mar 2013 00:06:36 +0100
From: Stefano Lattarini <stefano.lattarini@HIDDEN>
MIME-Version: 1.0
To: Bastien ROUCARIES <roucaries.bastien@HIDDEN>
Subject: Re: bug#7328: Any news of this bug
References: <m3eib1ktes.fsf@HIDDEN>
	<CAE2SPAac2VGBoxD=4iDBT-t3FQ=N5hycZe+KPObquAoX3am61Q@HIDDEN>
In-Reply-To: <CAE2SPAac2VGBoxD=4iDBT-t3FQ=N5hycZe+KPObquAoX3am61Q@HIDDEN>
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 7bit
X-Spam-Score: 0.1 (/)
X-Debbugs-Envelope-To: 7328
Cc: 7328 <at> debbugs.gnu.org
X-BeenThere: debbugs-submit <at> debbugs.gnu.org
X-Mailman-Version: 2.1.13
Precedence: list
List-Id: <debbugs-submit.debbugs.gnu.org>
List-Unsubscribe: <http://debbugs.gnu.org/cgi-bin/mailman/options/debbugs-submit>,
	<mailto:debbugs-submit-request <at> debbugs.gnu.org?subject=unsubscribe>
List-Archive: <http://debbugs.gnu.org/cgi-bin/mailman/private/debbugs-submit>
List-Post: <mailto:debbugs-submit <at> debbugs.gnu.org>
List-Help: <mailto:debbugs-submit-request <at> debbugs.gnu.org?subject=help>
List-Subscribe: <http://debbugs.gnu.org/cgi-bin/mailman/listinfo/debbugs-submit>,
	<mailto:debbugs-submit-request <at> debbugs.gnu.org?subject=subscribe>
Sender: debbugs-submit-bounces <at> debbugs.gnu.org
Errors-To: debbugs-submit-bounces <at> debbugs.gnu.org
X-Spam-Score: -2.6 (--)

Reference: <http://debbugs.gnu.org/cgi/bugreport.cgi?bug=7328>

On 03/29/2013 09:44 PM, Bastien ROUCARIES wrote:
> We have been it by this bug on imagemagick source.
> 
> Any news of a solution ?
> 
No, sorry.  Moreover, this is a part of Automake I don't know well
(nor even decently actually), and I won't have time to look into it anytime
soon.  And even when I'll have the time and the mental bandwidth, there is
more pressing stuff I'll have to deal with before.

In the meantime, does the workaround suggested by Ralf work for you?

Regards, and sorry not to be more helpful,
  Stefano




Information forwarded to bug-automake@HIDDEN:
bug#7328; Package automake. Full text available.

Message received at 7328 <at> debbugs.gnu.org:


Received: (at 7328) by debbugs.gnu.org; 29 Mar 2013 20:46:56 +0000
From debbugs-submit-bounces <at> debbugs.gnu.org Fri Mar 29 16:46:56 2013
Received: from localhost ([127.0.0.1]:51397 helo=debbugs.gnu.org)
	by debbugs.gnu.org with esmtp (Exim 4.72)
	(envelope-from <debbugs-submit-bounces <at> debbugs.gnu.org>)
	id 1ULgCN-0008PT-To
	for submit <at> debbugs.gnu.org; Fri, 29 Mar 2013 16:46:56 -0400
Received: from mail-oa0-f42.google.com ([209.85.219.42]:45261)
	by debbugs.gnu.org with esmtp (Exim 4.72)
	(envelope-from <roucaries.bastien@HIDDEN>) id 1ULgCK-0008PD-0N
	for 7328 <at> debbugs.gnu.org; Fri, 29 Mar 2013 16:46:52 -0400
Received: by mail-oa0-f42.google.com with SMTP id i18so663693oag.15
	for <7328 <at> debbugs.gnu.org>; Fri, 29 Mar 2013 13:44:14 -0700 (PDT)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=20120113;
	h=mime-version:x-received:date:message-id:subject:from:to
	:content-type; bh=ue8e2nmxy2TBynY0kHLL/Ku7/wiYe+ygXuVmx6dro8I=;
	b=Ct51HMBKoNwSkIsK5f+srqtK9o8PVUp9oQMfbcpjTx6FVWCfz8eTLoJsM9G2ar75Be
	SS4Ii4m3usyZ6MzfJdURYZk0qwuu5EFatDoOjjfBzLoQKrGH9j8aktT/sUmabowjpCL9
	UPnP1ADT+yfgcMXWbfc36KXyitC1YokoOrCeg1jqv07DGZMAbwuX5fHVRbFyUrfDi6wX
	xyutcKP3uuuDDZ21jk1hzj+xzHBZpnxiuBHbkY+uHRDh7EsXDrAQ/sas9hQVGACshGQy
	u9Nj1PsNunMTkS/BoZ+N/y7IfDY61UNXA/QjsJkiAMr6cpz8BBS3g3nPPxJCZwWJkhfJ
	iDoA==
MIME-Version: 1.0
X-Received: by 10.182.2.198 with SMTP id 6mr1268604obw.8.1364589853882; Fri,
	29 Mar 2013 13:44:13 -0700 (PDT)
Received: by 10.60.171.139 with HTTP; Fri, 29 Mar 2013 13:44:13 -0700 (PDT)
Date: Fri, 29 Mar 2013 21:44:13 +0100
Message-ID: <CAE2SPAac2VGBoxD=4iDBT-t3FQ=N5hycZe+KPObquAoX3am61Q@HIDDEN>
Subject: Any news of this bug
From: Bastien ROUCARIES <roucaries.bastien@HIDDEN>
To: 7328 <at> debbugs.gnu.org
Content-Type: text/plain; charset=UTF-8
X-Spam-Score: 0.1 (/)
X-Debbugs-Envelope-To: 7328
X-BeenThere: debbugs-submit <at> debbugs.gnu.org
X-Mailman-Version: 2.1.13
Precedence: list
List-Id: <debbugs-submit.debbugs.gnu.org>
List-Unsubscribe: <http://debbugs.gnu.org/cgi-bin/mailman/options/debbugs-submit>,
	<mailto:debbugs-submit-request <at> debbugs.gnu.org?subject=unsubscribe>
List-Archive: <http://debbugs.gnu.org/cgi-bin/mailman/private/debbugs-submit>
List-Post: <mailto:debbugs-submit <at> debbugs.gnu.org>
List-Help: <mailto:debbugs-submit-request <at> debbugs.gnu.org?subject=help>
List-Subscribe: <http://debbugs.gnu.org/cgi-bin/mailman/listinfo/debbugs-submit>,
	<mailto:debbugs-submit-request <at> debbugs.gnu.org?subject=subscribe>
Sender: debbugs-submit-bounces <at> debbugs.gnu.org
Errors-To: debbugs-submit-bounces <at> debbugs.gnu.org
X-Spam-Score: -0.7 (/)

We have been it by this bug on imagemagick source.

Any news of a solution ?

Bastien




Information forwarded to bug-automake@HIDDEN:
bug#7328; Package automake. Full text available.

Message received at 7328 <at> debbugs.gnu.org:


Received: (at 7328) by debbugs.gnu.org; 4 Nov 2010 20:19:48 +0000
From debbugs-submit-bounces <at> debbugs.gnu.org Thu Nov 04 16:19:48 2010
Received: from localhost ([127.0.0.1] helo=debbugs.gnu.org)
	by debbugs.gnu.org with esmtp (Exim 4.69)
	(envelope-from <debbugs-submit-bounces <at> debbugs.gnu.org>)
	id 1PE6Hc-0006JO-4O
	for submit <at> debbugs.gnu.org; Thu, 04 Nov 2010 16:19:48 -0400
Received: from mailout-de.gmx.net ([213.165.64.23] helo=mail.gmx.net)
	by debbugs.gnu.org with smtp (Exim 4.69)
	(envelope-from <Ralf.Wildenhues@HIDDEN>) id 1PE6Ha-0006JJ-50
	for 7328 <at> debbugs.gnu.org; Thu, 04 Nov 2010 16:19:39 -0400
Received: (qmail invoked by alias); 04 Nov 2010 20:24:05 -0000
Received: from xdsl-89-0-191-250.netcologne.de (EHLO localhost.localdomain)
	[89.0.191.250]
	by mail.gmx.net (mp017) with SMTP; 04 Nov 2010 21:24:05 +0100
X-Authenticated: #13673931
X-Provags-ID: V01U2FsdGVkX18GTB9dSCkGbPkRHAX21fx5XjXCOrVZIFKiK65wFm
	HMmt1uRECwn5sz
Received: from ralf by localhost.localdomain with local (Exim 4.69)
	(envelope-from <Ralf.Wildenhues@HIDDEN>)
	id 1PE6Lr-0003WE-TG; Thu, 04 Nov 2010 21:24:03 +0100
Date: Thu, 4 Nov 2010 21:24:03 +0100
From: Ralf Wildenhues <Ralf.Wildenhues@HIDDEN>
To: Andy Wingo <wingo@HIDDEN>
Subject: Re: bug#7328: parallel installation ignores deps between libtool
	libraries
Message-ID: <20101104202403.GO9168@HIDDEN>
References: <m3eib1ktes.fsf@HIDDEN>
MIME-Version: 1.0
Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline
In-Reply-To: <m3eib1ktes.fsf@HIDDEN>
Organization: Institute for Numerical Simulation, University of Bonn
User-Agent: Mutt/1.5.20 (2010-08-04)
X-Y-GMX-Trusted: 0
X-Spam-Score: -2.8 (--)
X-Debbugs-Envelope-To: 7328
Cc: Ben Denckla <bdenckla@HIDDEN>, 7328 <at> debbugs.gnu.org
X-BeenThere: debbugs-submit <at> debbugs.gnu.org
X-Mailman-Version: 2.1.11
Precedence: list
List-Id: <debbugs-submit.debbugs.gnu.org>
List-Unsubscribe: <http://debbugs.gnu.org/cgi-bin/mailman/options/debbugs-submit>,
	<mailto:debbugs-submit-request <at> debbugs.gnu.org?subject=unsubscribe>
List-Archive: <http://debbugs.gnu.org/pipermail/debbugs-submit>
List-Post: <mailto:debbugs-submit <at> debbugs.gnu.org>
List-Help: <mailto:debbugs-submit-request <at> debbugs.gnu.org?subject=help>
List-Subscribe: <http://debbugs.gnu.org/cgi-bin/mailman/listinfo/debbugs-submit>,
	<mailto:debbugs-submit-request <at> debbugs.gnu.org?subject=subscribe>
Sender: debbugs-submit-bounces <at> debbugs.gnu.org
Errors-To: debbugs-submit-bounces <at> debbugs.gnu.org
X-Spam-Score: -2.8 (--)

Hi Andy,

* Andy Wingo wrote on Thu, Nov 04, 2010 at 04:19:55PM CET:
>     lib_LTLIBRARIES = libfoo.la
>     plugindir = $(libdir)/gstreamer-0.10
>     plugin_LTLIBRARIES = bar.la
>     bar_la_LIBADD = libfoo.la
> 
> Obviously we are missing some sources here, but it suffices to show the
> parallel installation bug: there is a race between relinking the
> installed bar.la and the installed libfoo.la. It could be that libfoo.la
> isn't there yet.

Yep; long-standing bug.  We've pondered about strategies to fix it
before, but no full solution yet.  Here's a dirty workaround for the
moment:

install-pluginLTLIBRARIES = install-pluginLTLIBRARIES
$(install-pluginLTLIBRARIES): install-libLTLIBRARIES

Thanks for the report,
Ralf




Information forwarded to owner <at> debbugs.gnu.org, bug-automake@HIDDEN:
bug#7328; Package automake. Full text available.

Message received at submit <at> debbugs.gnu.org:


Received: (at submit) by debbugs.gnu.org; 4 Nov 2010 15:26:12 +0000
From debbugs-submit-bounces <at> debbugs.gnu.org Thu Nov 04 11:26:12 2010
Received: from localhost ([127.0.0.1] helo=debbugs.gnu.org)
	by debbugs.gnu.org with esmtp (Exim 4.69)
	(envelope-from <debbugs-submit-bounces <at> debbugs.gnu.org>)
	id 1PE1hb-0003Em-75
	for submit <at> debbugs.gnu.org; Thu, 04 Nov 2010 11:26:12 -0400
Received: from eggs.gnu.org ([140.186.70.92])
	by debbugs.gnu.org with esmtp (Exim 4.69)
	(envelope-from <wingo@HIDDEN>) id 1PE1Zo-0003BJ-Nx
	for submit <at> debbugs.gnu.org; Thu, 04 Nov 2010 11:18:09 -0400
Received: from Debian-exim by eggs.gnu.org with spam-scanned (Exim 4.71)
	(envelope-from <wingo@HIDDEN>) id 1PE1e7-0000gU-7Y
	for submit <at> debbugs.gnu.org; Thu, 04 Nov 2010 11:22:36 -0400
X-Spam-Checker-Version: SpamAssassin 3.3.1 (2010-03-16) on eggs.gnu.org
X-Spam-Level: 
X-Spam-Status: No, score=-1.9 required=5.0 tests=BAYES_00
	autolearn=unavailable version=3.3.1
Received: from lists.gnu.org ([199.232.76.165]:51288)
	by eggs.gnu.org with esmtp (Exim 4.71)
	(envelope-from <wingo@HIDDEN>) id 1PE1e7-0000gO-0x
	for submit <at> debbugs.gnu.org; Thu, 04 Nov 2010 11:22:35 -0400
Received: from [140.186.70.92] (port=49855 helo=eggs.gnu.org)
	by lists.gnu.org with esmtp (Exim 4.43) id 1PE1e4-0008CT-HF
	for bug-automake@HIDDEN; Thu, 04 Nov 2010 11:22:33 -0400
Received: from Debian-exim by eggs.gnu.org with spam-scanned (Exim 4.71)
	(envelope-from <wingo@HIDDEN>) id 1PE1dy-0000e7-Nj
	for bug-automake@HIDDEN; Thu, 04 Nov 2010 11:22:30 -0400
Received: from smtp-1.01.com ([38.102.63.180]:42165)
	by eggs.gnu.org with esmtp (Exim 4.71)
	(envelope-from <wingo@HIDDEN>) id 1PE1dy-0000do-GD
	for bug-automake@HIDDEN; Thu, 04 Nov 2010 11:22:26 -0400
Received: from localhost (localhost.localdomain [127.0.0.1])
	by smtp-1.01.com (Postfix) with ESMTP id E468336D091;
	Thu,  4 Nov 2010 10:22:23 -0500 (CDT)
Received: from smtp-1.01.com ([127.0.0.1])
	by localhost (smtp-1.01.com [127.0.0.1]) (amavisd-new, port 10024)
	with ESMTP id o+NA8A8TyUPU; Thu,  4 Nov 2010 10:22:23 -0500 (CDT)
Received: from harpy.local (74.Red-80-24-4.staticIP.rima-tde.net [80.24.4.74])
	by smtp-1.01.com (Postfix) with ESMTPSA id 212013645F1;
	Thu,  4 Nov 2010 10:22:22 -0500 (CDT)
From: Andy Wingo <wingo@HIDDEN>
To: bug-automake@HIDDEN
Subject: parallel installation ignores deps between libtool libraries
Date: Thu, 04 Nov 2010 16:19:55 +0100
Message-ID: <m3eib1ktes.fsf@HIDDEN>
User-Agent: Gnus/5.13 (Gnus v5.13) Emacs/23.2 (gnu/linux)
MIME-Version: 1.0
Content-Type: text/plain; charset=us-ascii
X-detected-operating-system: by eggs.gnu.org: Genre and OS details not
	recognized.
X-detected-operating-system: by eggs.gnu.org: GNU/Linux 2.6 (newer, 2)
X-Spam-Score: -6.6 (------)
X-Debbugs-Envelope-To: submit
X-Mailman-Approved-At: Thu, 04 Nov 2010 11:26:09 -0400
Cc: Ben Denckla <bdenckla@HIDDEN>
X-BeenThere: debbugs-submit <at> debbugs.gnu.org
X-Mailman-Version: 2.1.11
Precedence: list
List-Id: <debbugs-submit.debbugs.gnu.org>
List-Unsubscribe: <http://debbugs.gnu.org/cgi-bin/mailman/options/debbugs-submit>,
	<mailto:debbugs-submit-request <at> debbugs.gnu.org?subject=unsubscribe>
List-Archive: <http://debbugs.gnu.org/pipermail/debbugs-submit>
List-Post: <mailto:debbugs-submit <at> debbugs.gnu.org>
List-Help: <mailto:debbugs-submit-request <at> debbugs.gnu.org?subject=help>
List-Subscribe: <http://debbugs.gnu.org/cgi-bin/mailman/listinfo/debbugs-submit>,
	<mailto:debbugs-submit-request <at> debbugs.gnu.org?subject=subscribe>
Sender: debbugs-submit-bounces <at> debbugs.gnu.org
Errors-To: debbugs-submit-bounces <at> debbugs.gnu.org
X-Spam-Score: -6.6 (------)

Hello

Consider a Makefile.am like this:

    lib_LTLIBRARIES = libfoo.la

    plugindir = $(libdir)/gstreamer-0.10
    plugin_LTLIBRARIES = bar.la
    bar_la_LIBADD = libfoo.la

Obviously we are missing some sources here, but it suffices to show the
parallel installation bug: there is a race between relinking the
installed bar.la and the installed libfoo.la. It could be that libfoo.la
isn't there yet.

Let me know if you need more info. Please Cc: me on replies.

Cheers,

Andy




Acknowledgement sent to Andy Wingo <wingo@HIDDEN>:
New bug report received and forwarded. Copy sent to bug-automake@HIDDEN. Full text available.
Report forwarded to owner <at> debbugs.gnu.org, bug-automake@HIDDEN:
bug#7328; Package automake. Full text available.
Please note: This is a static page, with minimal formatting, updated once a day.
Click here to see this page with the latest information and nicer formatting.
Last modified: Fri, 31 Oct 2014 17:00:04 UTC

GNU bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997 nCipher Corporation Ltd, 1994-97 Ian Jackson.