GNU bug report logs - #9489
Avoiding installation of .la files

Please note: This is a static page, with minimal formatting, updated once a day.
Click here to see this page with the latest information and nicer formatting.

Package: libtool; Reported by: Reuben Thomas <rrt@HIDDEN>; dated Tue, 13 Sep 2011 01:39:02 UTC; Maintainer for libtool is bug-libtool@HIDDEN.

Message received at submit <at> debbugs.gnu.org:


Received: (at submit) by debbugs.gnu.org; 13 Sep 2011 01:38:44 +0000
From debbugs-submit-bounces <at> debbugs.gnu.org Mon Sep 12 21:38:44 2011
Received: from localhost ([127.0.0.1] helo=debbugs.gnu.org)
	by debbugs.gnu.org with esmtp (Exim 4.69)
	(envelope-from <debbugs-submit-bounces <at> debbugs.gnu.org>)
	id 1R3HxU-00040T-Ch
	for submit <at> debbugs.gnu.org; Mon, 12 Sep 2011 21:38:44 -0400
Received: from eggs.gnu.org ([140.186.70.92])
	by debbugs.gnu.org with esmtp (Exim 4.69)
	(envelope-from <rrt@HIDDEN>) id 1R3HxR-00040K-Hg
	for submit <at> debbugs.gnu.org; Mon, 12 Sep 2011 21:38:43 -0400
Received: from Debian-exim by eggs.gnu.org with spam-scanned (Exim 4.71)
	(envelope-from <rrt@HIDDEN>) id 1R3Ht9-0006eU-OA
	for submit <at> debbugs.gnu.org; Mon, 12 Sep 2011 21:34:17 -0400
X-Spam-Checker-Version: SpamAssassin 3.3.1 (2010-03-16) on eggs.gnu.org
X-Spam-Level: 
X-Spam-Status: No, score=-4.2 required=5.0 tests=BAYES_00,RCVD_IN_DNSWL_MED
	autolearn=unavailable version=3.3.1
Received: from lists.gnu.org ([140.186.70.17]:39278)
	by eggs.gnu.org with esmtp (Exim 4.71) (envelope-from <rrt@HIDDEN>)
	id 1R3Ht9-0006eO-Mj
	for submit <at> debbugs.gnu.org; Mon, 12 Sep 2011 21:34:15 -0400
Received: from eggs.gnu.org ([140.186.70.92]:37742)
	by lists.gnu.org with esmtp (Exim 4.71)
	(envelope-from <rrt@HIDDEN>) id 1R3Ht5-0003GU-NQ
	for bug-libtool@HIDDEN; Mon, 12 Sep 2011 21:34:15 -0400
Received: from Debian-exim by eggs.gnu.org with spam-scanned (Exim 4.71)
	(envelope-from <rrt@HIDDEN>) id 1R3Ht4-0006cy-Ka
	for bug-libtool@HIDDEN; Mon, 12 Sep 2011 21:34:11 -0400
Received: from exprod7og120.obsmtp.com ([64.18.2.18]:53111)
	by eggs.gnu.org with smtp (Exim 4.71) (envelope-from <rrt@HIDDEN>)
	id 1R3Ht4-0006cI-BT
	for bug-libtool@HIDDEN; Mon, 12 Sep 2011 21:34:10 -0400
Received: from mail-yw0-f54.google.com ([209.85.213.54]) (using TLSv1) by
	exprod7ob120.postini.com ([64.18.6.12]) with SMTP
	ID DSNKTm6zEN5DWSPZQO06/7GWF5USkbGpGsor@HIDDEN;
	Mon, 12 Sep 2011 18:34:10 PDT
Received: by mail-yw0-f54.google.com with SMTP id 17so55470ywp.27
	for <bug-libtool@HIDDEN>; Mon, 12 Sep 2011 18:34:08 -0700 (PDT)
MIME-Version: 1.0
Received: by 10.231.26.28 with SMTP id b28mr7124808ibc.42.1315877647641; Mon,
	12 Sep 2011 18:34:07 -0700 (PDT)
Received: by 10.231.145.145 with HTTP; Mon, 12 Sep 2011 18:34:07 -0700 (PDT)
Date: Tue, 13 Sep 2011 02:34:07 +0100
Message-ID: <CAOnWdojXGujqmU+2wZ_ncah71OYyR1GaozUW4o_4HH8YM9J79g@HIDDEN>
Subject: Avoiding installation of .la files
From: Reuben Thomas <rrt@HIDDEN>
To: bug-libtool@HIDDEN
Content-Type: text/plain; charset=ISO-8859-1
X-detected-operating-system: by eggs.gnu.org: GNU/Linux 2.6, seldom 2.4 (older,
	4)
X-detected-operating-system: by eggs.gnu.org: GNU/Linux 2.6 (newer, 3)
X-Received-From: 140.186.70.17
X-Spam-Score: -6.2 (------)
X-Debbugs-Envelope-To: submit
X-BeenThere: debbugs-submit <at> debbugs.gnu.org
X-Mailman-Version: 2.1.11
Precedence: list
List-Id: <debbugs-submit.debbugs.gnu.org>
List-Unsubscribe: <http://debbugs.gnu.org/cgi-bin/mailman/options/debbugs-submit>,
	<mailto:debbugs-submit-request <at> debbugs.gnu.org?subject=unsubscribe>
List-Archive: <http://debbugs.gnu.org/cgi-bin/mailman/private/debbugs-submit>
List-Post: <mailto:debbugs-submit <at> debbugs.gnu.org>
List-Help: <mailto:debbugs-submit-request <at> debbugs.gnu.org?subject=help>
List-Subscribe: <http://debbugs.gnu.org/cgi-bin/mailman/listinfo/debbugs-submit>,
	<mailto:debbugs-submit-request <at> debbugs.gnu.org?subject=subscribe>
Sender: debbugs-submit-bounces <at> debbugs.gnu.org
Errors-To: debbugs-submit-bounces <at> debbugs.gnu.org
X-Spam-Score: -6.2 (------)

I'm building Lua plugins with libtool. Lua plugins are dlopened
dynamic libraries, so don't use libltdl, and hence don't need (and
indeed, cannot use) .la files. How can I avoid installing the .la
files for my .so (or .dylib, .dll or whatever) files on "make
install"?

-- 
http://rrt.sc3d.org




Acknowledgement sent to Reuben Thomas <rrt@HIDDEN>:
New bug report received and forwarded. Copy sent to bug-libtool@HIDDEN. Full text available.
Report forwarded to owner <at> debbugs.gnu.org, bug-libtool@HIDDEN:
bug#9489; Package libtool. Full text available.
Please note: This is a static page, with minimal formatting, updated once a day.
Click here to see this page with the latest information and nicer formatting.
Last modified: Fri, 31 Oct 2014 17:00:04 UTC

GNU bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997 nCipher Corporation Ltd, 1994-97 Ian Jackson.